Category Archives: bigtop

Oozie Setup does not work

Yet another problem with Apache Bigtop. This time it is oozie.

Whenever I want to do something with Oozie, I get the following exception:

java.lang.IllegalArgumentException: Oozie URL is not available neither in command option or in the environment

I did some google-fuu and came across the tutorial officially provided by them.

But hurray, next problem:

Whenever I enter

bin/oozie-setup.sh -hadoop 2.6.0 $HADOOP_HOME -extjs ext-2.2.zip

I get the following reply:

  setting OOZIE_DATA=/var/lib/oozie
  setting OOZIE_CATALINA_HOME=/usr/lib/bigtop-tomcat
  setting CATALINA_TMPDIR=/var/lib/oozie
  setting CATALINA_PID=/var/run/oozie/oozie.pid
  setting CATALINA_BASE=/var/lib/oozie/tomcat-deployment
  setting CATALINA_OPTS="$CATALINA_OPTS -Xmx1024m"
  setting OOZIE_CONFIG=/etc/oozie/conf
  setting OOZIE_LOG=/var/log/oozie
  setting OOZIE_DATA=/var/lib/oozie
  setting OOZIE_CATALINA_HOME=/usr/lib/bigtop-tomcat
  setting CATALINA_TMPDIR=/var/lib/oozie
  setting CATALINA_PID=/var/run/oozie/oozie.pid
  setting CATALINA_BASE=/var/lib/oozie/tomcat-deployment
  setting CATALINA_OPTS="$CATALINA_OPTS -Xmx1024m"
  setting OOZIE_CONFIG=/etc/oozie/conf
  setting OOZIE_LOG=/var/log/oozie

 Usage  : oozie-setup.sh <Command and OPTIONS>
          prepare-war [-d directory] [-secure] (-d identifies an alternative directory for processing jars
                                                -secure will configure the war file to use HTTPS (SSL))
          sharelib create -fs FS_URI [-locallib SHARED_LIBRARY] (create sharelib for oozie,
                                                                FS_URI is the fs.default.name
                                                                for hdfs uri; SHARED_LIBRARY, path to the
                                                                Oozie sharelib to install, it can be a tarball
                                                                or an expanded version of it. If ommited,
                                                                the Oozie sharelib tarball from the Oozie
                                                                installation directory will be used)
                                                                (action failes if sharelib is already installed
                                                                in HDFS)
          sharelib upgrade -fs FS_URI [-locallib SHARED_LIBRARY] (upgrade existing sharelib, fails if there
                                                                  is no existing sharelib installed in HDFS)
          db create|upgrade|postupgrade -run [-sqlfile <FILE>] (create, upgrade or postupgrade oozie db with an
                                                                optional sql File)
          (without options prints this usage information)

 EXTJS can be downloaded from http://www.extjs.com/learn/Ext_Version_Archives

I have tried quiet a lot of things. I downloaded a version of ext-2.2.zip from an archive. I downloaded the version 2.3.0. But no matter what I do, the reply stays the same. Please help me get Oozie to run. I desperately need it right now!