Category Archives: appserver

AppServ with Alias access through intranet

Im trying to configure AppServ with an Alias for one of my projects. I used the instructions from here and it works the problem I have is that I am unable to access it from another computer.

localhost works fine on the local machine. test.localhost (alias) also works fine. The problem is only when i try to access the project from another machine on the intranet.

Current vhost lines ServerAdmin [email protected] DocumentRoot "C:/AppServ/www" ServerName localhost ServerAlias localhost ErrorLog "logs/localhost-error.log" CustomLog "logs/localhost-access.log" common

<VirtualHost *:80>
ServerName [email protected]
DocumentRoot "C:/AppServ/www/test"
ServerName test.localhost
ErrorLog "logs/test-error.log"
CustomLog "logs/test-access.log" common
</VirtualHost>

So far I have been able to access the project from any computer as long as is not a vhost/alias

Im using apache 2.4 on a windows 7 pc

AppServ with Alias access through intranet

Im trying to configure AppServ with an Alias for one of my projects. I used the instructions from here and it works the problem I have is that I am unable to access it from another computer.

localhost works fine on the local machine. test.localhost (alias) also works fine. The problem is only when i try to access the project from another machine on the intranet.

Current vhost lines ServerAdmin [email protected] DocumentRoot "C:/AppServ/www" ServerName localhost ServerAlias localhost ErrorLog "logs/localhost-error.log" CustomLog "logs/localhost-access.log" common

<VirtualHost *:80>
ServerName [email protected]
DocumentRoot "C:/AppServ/www/test"
ServerName test.localhost
ErrorLog "logs/test-error.log"
CustomLog "logs/test-access.log" common
</VirtualHost>

So far I have been able to access the project from any computer as long as is not a vhost/alias

Im using apache 2.4 on a windows 7 pc

need help setting up appserv on windows 2008 with non port 80

first of all im really sorry if my question kinda hard to understand and grammar mistake

i need some help to configure my domain hosted on windows server 2008 ...on my server port 80 already allocated to other services and i cant change that port,so i change on my httpd configuration to listen to port 8080 (well any other port is no problem as long not port 80) ,but after i changed that my website is unable to load unless i manually typing port number at url ending for example www.domain.com:8080

How do i load my website without me having to type port number and remove that port number on url bar/address bar (i mean when the website load,the url is formatted as www.domain.com:8080 ?

Thanks

Virtual host with XAMP and APPSERVER

I have XAMPP and Appserver installed in one server (The first listens port 8080 and the second listens port 80).

I have a domain: example.com

I have this in APPSERV:

<VirtualHost 1.2.3.4:80>  
    ServerName example.com  
    DirectoryIndex index.php index.html  
    DocumentRoot "C:/appserv/www/folder"  
</VirtualHost>

Is there a way so I can send that request to port 8080?

apache web server url is changed to jboss server’s url

I have configured apache web server with jboss and integrated using mod_jk, now the problem is when i hit the url of webserver http://web1000.my.project.com:8080/index.html, after login to the application the url is automatically changed to appserver that is http://app1000.my.project.com:8080/login.jsp, problem: url is changed to application server expected: url should be same as webserver throughout the session